我们在跨环境开发时,通常会为了测试而烦恼,此时我们需要VMware Workstation Pro 虚拟机软件来安装虚拟系统来进行测试工作;VMware Workstation可以创建真实的Linux、Mac、Android、Windows等桌面系统以及虚拟的网络环境。

VMware Workstation 16 Pro 发行说明

[ 以下内容为官网发行说明翻译而来 ]

发行说明目录

  • 关于 VMware Workstation Pro
  • 系统要求
  • 新增功能
  • 公共支持通知
  • 重要修复
  • 已解决的问题
  • 已知问题

关于 VMware Workstation Pro

VMware Workstation Pro™允许技术专业人员通过在同一台PC上同时运行多个基于x86的Windows、Linux和其他操作系统来开发、测试、演示和部署软件。您可以在虚拟机中复制服务器、桌面和平板环境,并为每个虚拟机分配多个处理器核心、千兆字节的主内存和图形内存,无论虚拟机位于个人PC上还是私有企业云上。

系统需求

支持2011年或以后推出的使用处理器(cpu)的系统,但以下情况除外:

基于2011 Bonnell微架构的英特尔Atom处理器。
例如,Atom Z670/Z650和Atom N570。
系统使用Intel Atom处理器,基于2012年的Saltwell微架构。
例如Atom S1200, Atom D2700/D2500, Atom N2800/N2600。
系统采用AMD处理器基于Llano和Bobcat微架构。
例如,代号为Hondo、Ontario、Zacate和Llano。
还支持以下系统:使用基于2010 Westmere微架构的英特尔处理器的系统。
例如,Xeon 5600、Xeon 3600、 Core i7-970、Core i7-980、 Core i7-990。

新增功能

  • 容器和Kubernetes支持

    • 使用vctl CLI 构建/运行/拉动/推动容器映像。
    • 支持在Workstation Pro上运行的KIND kubernetes群集。
注意:需要Windows 10 1809或更高版本。
  • 支持全新客户操作系统

    • RHEL 8.2
    • Debian 10.5
    • Fedora 32
    • CentOS 8.2
    • SLE 15 SP2 GA
    • FreeBSD 11.4
    • ESXi 7.0
  • 新的客户端支持Directx11和Opengl4.1

    • 硬件要求:
      • 对于Windows主机,需要支持DirectX 11.0的GPU。
      • 对于Linux主机,需要NVIDIA GPU。
    • 软件要求:
      • 主机操作系统(64位):
        • Windows 8或更高版本;
        • GNU/Linux,带有支持OpenGL 4.5及更高版本的NVIDIA驱动程序。
      • 客户操作系统:
        • Windows 7或更高版本;
        • 带vmwgfx的GNU/Linux。
  • Linux工作站的Vulkan渲染支持

Workstation 16 Pro支持Linux主机上的Intel GPU的3D支持,使用Vulkan渲染器将DirectX 10.1和OpenGL 3.3提供给虚拟机。

注意:需要安装最新Intel/Vulkan驱动程序的Linux主机操作系统,建议使用Mesa 20.1或更高版本。

  • 沙盒图形

通过从vmx中删除图形呈现并将其作为单独的沙盒进程运行,可以增强虚拟机的安全性。

  • USB 3.1控制器支持

虚拟机从支持10.Gbps的虚拟机更改为支持USB 3.0的虚拟机。

  • 更大的虚拟机

    • 32个虚拟CPU;
    • 128 GB虚拟内存;

注意:运行带有32个vCPU的虚拟机需要主机和来宾操作系统都支持32个逻辑处理器。

    • 8 GB虚拟图形内存。
  • 深色模式

Workstation 16 Pro支持暗模式,优化用户体验。

注意:要求主机操作系统为Windows 10 1809或更高版本。

  • vSphere 7.0支持

Workstation 16 Pro中,您可以执行以下操作:

    • 连接到vSphere 7.0。
    • 将本地虚拟机上载到vSphere 7.0。
    • 将运行在vSphere 7.0上的远程虚拟机下载到本地桌面。
  • 性能改进

    • 提高了文件传输速度(拖放、复制和粘贴)
    • 缩短了虚拟机关闭时间。
    • 改进了虚拟NVMe存储性能。
  • 改进的易访问性支持

已添加辅助功能改进,因此Workstation Pro符合WCAG 2.1标准。

产品支持通知

  • 删除共享虚拟机功能

共享虚拟机(作为服务器的工作站)已过期,已从VMware Workstation 16中删除。

  • 删除受限制的虚拟机

受限虚拟机已过期,已从VMware Workstation 16中删除。

重要修复

此版本的VMware Workstation解决了以下问题:

  • 工作站解决了Cortado Thinprint组件中的多个越界读取漏洞。常见漏洞和暴露项目(网址:cve.mitre.org)已将标识符CVE-2020-3986、CVE-2020-3987和CVE-2020-3988分配给这些问题。有关更多信息,请参阅VMSA-2020-0020。
  • Workstation解决了由Cortado Thinprint组件中的越界写入问题导致的拒绝服务漏洞。常见漏洞和暴露项目(网址:cve.mitre.org)已将标识符CVE-2020-3989分配给此问题。有关更多信息,请参阅VMSA-2020-0020。
  • 工作站解决了Cortado Thinprint组件中整数溢出问题导致的信息泄漏漏洞。常见漏洞和暴露项目(网址:cve.mitre.org)已将标识符CVE-2020-3990分配给此问题。有关更多信息,请参阅VMSA-2020-0020。

解决的问题

  • 之后优先权.ungrabbed=“低”在虚拟机配置文件中设置,当在主机任务管理器上选中时,vmware vmx进程的优先级显示为正常。

此设置在Workstation Pro 15.5发布之前一直有效,但在15.5.5版本中,进程状态保持正常。
这个问题现在解决了。

  • 当工作站在启用Hyper-V的Win10主机上运行时,Windows XP x64虚拟机在引导期间冻结。

MSFT在APIC虚拟化中存在阻止winxpsp2启动过程的bug。
这个问题现在解决了。

已知问题

  • 轻松安装操作完成后,信息栏显示需要手动安装VMware工具。

“轻松安装”不会在某些来宾操作系统(包括Windows 7、Windows server 2012 R2和Windows server 2008 R2)中安装VMware工具。这是因为某些特定的Windows更新包需要在安装VMware工具之前手动安装。

解决方法:在客户端操作系统准备就绪后执行以下步骤:

对于Windows 7和Windows server 2008 R2客户端:

    1. 查看此处提供的信息:https://support.microsoft.com/en-us/help/4472027/2019-sha-2-code-signing-support-requirement-for-windows-and-wsus。
    2. 下载并安装所需的Windows更新,网址为https://support.microsoft.com/en-us/help/4474419/sha-2-code-signing-support-update以及https://support.microsoft.com/en-us/help/4490628/servicing-stack-update-for-windows-7-sp1-and-windows-server-2008-r2。

对于Windows server 2012 R2客户端:

    1. 手动获取Windows update,然后从下载并安装更新包(KB2919355)https://www.microsoft.com/en-ca/download/details.aspx?编号=42334
    2. 安装.NET 3.5 Framework。
    3. 在来宾操作系统中手动安装VMware工具。
  • 在以HDD(硬盘驱动器)作为系统磁盘的计算机上使用vctl CLI时,可能会出现性能低下或故障

当您在使用HDD(硬盘驱动器)的机器上运行vctl命令时,命令执行可能非常慢甚至失败。
解决方法:建议在带有SSD(固态驱动器)的计算机上使用vctl CLI。

以上为官方发行说明翻译而来,将就看着,另外附上官方地址:点击访问

本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。

最常见的情况是下载不完整: 可对比下载完压缩包的与网盘上的容量,若小于网盘提示的容量则是这个原因。这是浏览器下载的bug,建议用百度网盘软件或迅雷下载。 若排除这种情况,可在对应资源底部留言或联络我们。